Unable to load publisher dashboard
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 12:18 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2020 - 12:00 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 08, 2020 - 11:34 PDT
This incident affected: Writer dashboards.