Publishing posts is slow
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Sep 02, 2020 - 13:40 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2020 - 13:22 PDT
Investigating
We're investigating performance issues related to publishing posts and sending scheduled posts.
Posted Sep 02, 2020 - 12:13 PDT
This incident affected: Substack publications, Writer dashboards, and Email delivery.