Email send delays
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 17:59 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 10, 2020 - 17:56 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2020 - 17:54 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 10, 2020 - 17:50 PDT
Investigating
We are currently investigating this issue.
Posted Sep 10, 2020 - 17:46 PDT
This incident affected: Writer dashboards and Email delivery.